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Introduction

About MYM2QIFW
MYM2QIFW is a Microsoft Windows program. It converts Managing
Your Money (MYM) Win V1.0 - V2.1, NationsBank MYM, Bank of
America MYM, , US Bank, Fleet Financial Group, Royal Bank of
Canada, New England Financial, and Citibank MYM into Quicken
Interchange Format (QIF) files. This conversion to QIF includes Money
and Investment accounts. Transfers, CheckFree payments, Category and
Account Allocations in Splits, Account, Security, and Category
Descriptions are also converted. A specified date range can be set to
allow specific portion of the dataset to be converted.

Conventions used in documentation
Words that are highlighted in bold Arial font indicate selections that are
to be made in the target application. Bold words separated by an arrow
(→) indicate hierarchical menu selections in the target application.
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System Requirments

Hardware
Minimum

Recommended

CPU

IBM-compatible 386

IBM-compatible Pentium

RAM

8 MB RAM

32 MB RAM

Hard Disk Space

16 MB free

100 MB free

Video

VGA 640x480

Super VGA 800x600 or more

Minimum

Recommended

Windows 3.x

Windows 9x, or Windows NT

Software

Operating System

Version 2.1a

MYMWin

Version 5.33

MYM2QIFW
Quicken

†

Version 5 through 7R3

Version 8 R4

†

The initial release of Quicken V7 (Quicken 98) does not import split allocations in QIF files
correctly. This is corrected in the Quicken V7 R3 maintenance release.
Translation procedure MYM2QIFW
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Installation

Running the MYM2QIFW Setup program
1.
2.

Start Microsoft Windows. On Windows NT systems login to an
account in the local Administrators group.
Insert the MYM2QIFW Setup disk into the drive.

3.

Select Start → Run (select File → Run in Win3.1).

4.

In the Run dialog box, type a:\setup and press Enter
(substitute the correct drive letter if it is other than a:).

5.

A message will appear prompting you to close all other running
programs. After doing that select Next.

6.

After reviewing the Readme file select Next.

7.

The default destination location for the program files appears.
You can select Browse to select a different drive and/or
directory. When finished select Next.

8.

The installation program can create backup copies of all files
replaced during the installation. These files will be used when
uninstalling and a rollback is requested. In either case system
files are only replaced when a more recent version is available
in the source archive. It is normally not necessary to roll back
the files when uninstalling. Select an option and then Next.
9. The prompt appears listing the default Program Group to put the
startup shortcut icons in. Make any changes and select Next.
10. A prompt appears stating that the setup is ready to start. Select
Next to continue.
11. After the setup files have been copied, a prompt will appear that
reports the successful completion. Select Finish to exit the
setup program.
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Program files
Filename

Size
(bytes)

Date

Version

Description

Mym2qifw.exe

473,600

04/19/99

5.32

Translator executable

Mym2qifw.hlp

04/19/99

5.32

Program help file

Mym2qifw.cnt

04/19/99

5.32

Help contents file

N/A

5.32

Initialization settings file

04/19/99

5.32

Printable instruction book

Mym2qifw.ini

N/A

Mym2qifw.rtf
cmdialog.vbx

18,688

04-28-93

2.1.0.5

Common Dialog Interface

gauge.vbx

31,440

10-21-92

02.0.9000.1

Progress bar display routine

msafinx.dll

31,744

04-28-93

1.00.000

Library containing IIF function

vbrun300.dll

398,416

05-06-94

03.00.0538

VB3 Run time library

xbs200.dll

296,832

08-15-95

2.50.1117

Installable ISAM

vbdb300.dll

95,200

04-25-95

3.00.0529

VB Data Access library

msajt112.dll

17,440

04-25-95

1.99.1605

Jet Engine library

msajt200.dll

995,136

08/15/95

2.50.1606

Jet Engine V2.5 library
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Translation processing steps

Pack MYM Windows data
When a record is deleted or edited in MYMWin; it is marked as deleted
but is not actually removed from the database. While the data access
parameters are set to ignore these records, it is important to run the Pack
command to be sure that these records are not included in the translated
output data.
1. Start the MYMWin program and open the MYMWin dataset
that is to be converted.
2.

Select Tools → Utilities → Pack Tables.

3.

At the "This may take a while!" prompt, select Yes.

4.

Select File → Exit to exit from the MYMWin program.

Start the MYM2QIFW translator program
1.

From the Windows Start Menu, select the Programs folder.

2.

Click on the MYM2QIFW folder.

3.

Click on the MYM2QIFW icon.

4.

At the initial MYM2QIFW Welcome screen select I Agree Continue. The Select Paths screen will appear.

Select Paths
At the Select Paths screen there are two file paths that need to be defined.
On the left side of the screen the MYM Data Files path is selected, and
on the right side of the screen the Output Files path is selected.

MYM Data Files path
By default the C:\MYMWin directory will be selected, if it exist. This is
normally where the MYMWin program is installed. If this is correct then
please skip to step 2 below.
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1.

From the Drives: drop down list, at the bottom left of the Select
Paths screen, select the drive where the MYMWin program is
installed.

2.

From the directory tree list, on the left side of the screen, select
the folder that contains the MYMWin Dataset files that are to be
translated. Normally this is a sub-folder of the folder that
contains the MYMWin program files.

MYMWin Dataset Files
MYM2QIFW requires the following files from the MYM Windows data
set. If for some reason the MYMWin dataset directory is not easily
found, we can use the Windows Find command to search for any one of
the following files. When found we can verify the dataset folder.
Filename
Keyfield
Account.dbf

INSTANCE

Accountl.dbf INSTANCE
Card.dbf

NAME

Inventor.dbf

INSTANCE

Sechist.dbf

SECURITY

Security.dbf

SECURITY

Splits.dbf

TRANS_INST

Trnalloc.dbf

INSTANCE

Output Files path
The QIF files, CSV files, and mym2qifw.log file are written to the
designated output directory. This can be any folder on the hard drive. We
recommend either using the same folder that the MYM2QIFW program
is installed in, or creating another empty folder to contain these
temporary files.
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1.

From the Drives: drop down list, at the bottom right of the
Select Paths screen, select the drive where the Output Files
should be written.

2.

From the directory tree list on the right side of the screen, select
the folder where the Output Files should be written.

3.

When both the MYM Data Files path and the Output Files path
are set, select Continue to proceed to Process Transactions.
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Process Transactions
By default the Start Date: is set to 1/1/30 and the End Date: is set to
12/31/99. You can set the range to include only all of the required
transactions.
1.

2.

3.
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If you have scheduled transactions that are beyond this End
Date:, please enter a later date using four digits for the year
(12/31/2001 for example).
Select Continue to begin the translation of the account
transactions. During processing the transaction quantities in the
account list will update. When this completes the words
Processing Complete will appear near the top left corner of the
screen, and the computer will beep.
Select View Log to open the mym2qifw.log file. If a translation
has been done using the same Output Files Path previously,
then the results of this run are appended to the end of the
mym2qifw.log file. Scroll to the end of the log file to check for
any error messages during this run.

4.

Close the log file. Select Continue on the MYM2QIFW screen
to return to the initial Welcome screen.

5.

Select End Program to close the MYM2QIFW window. You
can now proceed to Importing data into Quicken.
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Importing data into Quicken

Translated data output files
A Quicken Interchange Format (QIF) file named allinone.qif is created in
the output directory when MYM2QIFW is run. There are also two
Comma Separated Values (CSV) files created.
1. Allinone.qif - contains the following data arranged in the file in
the order listed.
•

Account definitions

•

Security definitions

•

Category definitions

•

Money account register transactions

•

Investment account register transactions

2.

Sechist.csv - contains the price history data

3.

Inventor.csv - contains the home inventory data

4.

Mymmemos.txt - contains text from long memo lines

Steps to import the allinone.qif file
1.

Start Quicken and close the Quicken New User Setup dialog, if
it opens.

2.

Select File/New from the drop down menus.

3.

Select a directory for the Quicken data set and enter a Filename
in the Create Quicken File dialog.

4.

Typically we want to de-select the pre-defined Home and
Business Categories, and use only those from our MYMWin
dataset. If so then select the Categories… button that is just
below the Save as type: box on the Create Quicken File
dialog. Set the pre-defined Categories as desired, and then select
OK.
Select OK on the Create Quicken File dialog.

5.
6.
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Select List → Accounts and then press the New button in the
Account List window. The Create New Account dialog should
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open (It may have already opened if this is the first visit to the
Account List).
7.

Select the Cash type and then select Next.

8.

Accept the default name (Cash Account) provided that it is not
the same as any account or category name in the MYMWin
dataset. Otherwise enter any other name, except do not use the
word Cash alone for the name. Select Next to continue.

9.

On the Cash Account Setup dialog select the Summary tab.

10. Select Done.
11. Select File → Import → QIF File
12. On the QIF Import dialog select Browse and then find and
select the Allinone.qif file that was created by MYM2QIFW.
13. Select all of the options in the Include in Import box. These
include Transactions, Account List, Category List, Special
Handling for Transfers, and Security List.
14. Select OK to continue.
15. Select Yes on any dialogs that appear during the import.
16. Select OK at the Successfully imported xxx items message.

Steps to import the sechist.csv file
1.

From within Quicken select Features → Investing →
Portfolio View or press <Ctrl+U>.

2.

Select File → Import → Import Prices.

3.

At the Import Price Data dialog enter the full path and filename
to the sechist.csv file. Then select OK.

4.

At the Successfully imported xx prices dialog select OK.

Steps to import the inventor.csv file
1.

In the Quicken Home Inventory module; select File → Import
→ Comma-separated from the drop down menu.

2.

At the Import Home Inventory Data dialog enter the full path
and filename to the inventor.csv file. Then select OK.

Next a dialog with two side by side lists will appear. The left list contains
all the field names used to track your items in Quicken Home Inventory.
You'll see the item description, location, resale value, the insurance
policy that covers the item, and so on. The right side list contains the
items tracked using MYMWin, from the inventor.csv file.
3.
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Choose the QHI field name in the left side list and then select
the word or words in the right side list that match the QHI field
name. Then select Match.
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4.
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Repeat step 3 for each field in the left side list.
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Frequently Asked Questions

Translating MYMWin data
Why is the memo line truncated after importing?
MYM2QIFW writes the entire first line of the MYMWin transaction
memo to the QIF file. Quicken imports this line up to the maximum
characters that Quicken allows in a memo line.

Importing data into Quicken
Why does the quantity of register transactions in
the mym2qifw.log file not match that reported by
the Quicken import function?
These quantities are not expected to match. This is due to the Quicken
Special Handling for Transfers, which omits some transfer transactions
when importing the QIF files.
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Troubleshooting

Error Messages and Correction Procedures
Error 3022 Can't have duplicate key; index changes
were unsuccessful.
We have found duplicate key errors, in MYM datasets, occurring about
the date where the data was upgraded from one version of MYM to the
next version of MYM. There may be other reasons why this can happen.

Correction Procedure:
Generally these duplicates are far enough apart in date order, that the
transactions splits are not affected. MYM2QIFW will omit any index
from the table when a duplicate key error occurs. The processing will
continue and will be much slower without the indexes. This is an alert
message only and there is no specific action that needs to be done.

Error 3170 Couldn't find installable ISAM.
An ISAM driver is used by the MS JetEngine, that MYM2QIFW calls
on, to read MYMWin file format. If the path to the ISAM driver in your
mym2qifw.ini file is invalid, or if the ISAM driver does not exist, you
may receive this error message.

Correction Procedure:
Review the <WinDir>\mym2qifw.ini file to see that the correct path to the
xbs200.dll file is in place, in the [Installable ISAMs] section, similar to
the following example:
[Installable ISAMs]
FoxPro 2.5=C:\WINNT\system\xbs200.dll
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Troubleshooting • 17

Other problem conditions
Start icon is selected and yet program initial screen
does not appear
MYM2QIFW is designed such that if a previous instance of the
MYM2QIFW program is loaded in memory, a second instance will not
start. This is to avoid a problem of two separate instances trying to access
the same file for writing. This condition can occur after an abnormal
shutdown leaving an object of the MYM2QIFW program remaining in
memory. This will be identified as a running instance and a second
instance will be prevented from starting.

Correction Procedure:
1.

Press Ctrl + Alt + Delete and then select Task Manager.

2.

Select the MYM2QIFW application in the Task Manager dialog.

3.

Select End Task.

Now the MYM2QIFW program should start normally by selecting the
Start → Programs → MYM2QIFW → MYM2QIFW program icon.
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More help

Quicken Help file
•

There is information describing the use of the Quicken
Interchange Format (QIF) files available in the Quicken help
file.

•

There are additional instructions on the method used to import
QIF files also available in the Quicken Help file.

Contacting Response Mechanics
After reviewing this help file and there is still a problem that can not be
solved, please visit our support pages at
http://www.RespMech.com/MYM2QIFW, send email to
Support@RespMech.com or call 1-314-530-1170 for additional
assistance.
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Glossary of Terms

Special Handling for Transfers
The Quicken Special Handling for Transfers will omit any transfer
amounts leaving an account. It will adjust the transaction total
accordingly when the transfer out amount is in a split. Then when the
destination account is imported, the transactions on both sides of the
transfer are created.

duplicate key errors
A condition where the value in a key field of a record is the same as the
value in the same key field in another record.

ISAM
Insertable Sequencial Access Method

MYM2QIFW
Managing Your Money (MYM) to QIF translator.

MYMWin
Windows version of the Managing Your Money program.

Comma Separated Values (CSV)
CSV files contain data delimited by commas, with strings surrounded by
double quotes.

Quicken Interchange Format (QIF)
A QIF file is just a holding area for data while you are exporting data
from MYMWin and importing that data file to a new Quicken data file.
QIF stands for "Quicken Interchange Format".
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